Zaiendo Wir sind die Community


Neueste Ankündigungen:
Zaiendo.de ist auf FaceBook und Youtube.

Witz des Tages:
Aufgabe für die Oberstufe eines Jungengymnasiums im Fach Biologie: "Beschreiben Sie die Vorteile der Kinderernährung durch Muttermilch." Die gemeinsam erarbeitete Antwort: "Muttermilch ist bekömmlich, billig, brennt nicht an, kocht nicht über, die Katze kommt nicht ran und die Verpackung ist äußerst geschmackvoll."

Teilen auf:
Twitter Facebook Stumble Upon Delicious Google

Themabewertung:
  • 0 Bewertung(en) - 0 im Durchschnitt
  • 1
  • 2
  • 3
  • 4
  • 5
[Problem] Windows 7 - RAM läuft voll ohne Prozess als Ursache
#1
Moin Leute,
bin jetzt einigermaßen verzweifelt und hoffe ihr könnt mir helfen.

Technische Details meines Systems:
Windows 7 Ultimate x64
4 Gigabyte RAM (2x2 GB DDR-2)

Habe seit etwa 2 Wochen immer wieder folgendes Problem: Manchmal benötigt mein System aus dem Nichts heraus sämtlichen verfügbaren Speicher. Sieht dann so aus dass es im TaskManager hochgeht von 1 Gigabyte Auslastung (normaler Betrieb) auf die maximal verfügbaren 3,9 Gigabyte.
Wenn die Auslastung erreicht wird ist der Rechner kaum noch steuerbar, hängt sich fast auf etc.
Im Taskmanager ist aber kein Prozess als Übeltäter auszumachen. Zwar braucht Firefox so seine 200.000 KB und auch SVC-Host genemigt sich gern mal 150.000 KB aber damit komme ich auf keinen Fall auf 4 GB!

Hier Screenshots wie das dann im TaskManager aussieht:
       
Wie ihr seht gibt es keinen Prozess der diesen riesigen Verbrauch hervorrufen könnte.

Ich habe mir nun den Process Explorer von Sysinternals geholt um damit vielleicht Aufschluss zu erhalten, bei ihm sieht es so aus:
   

Das wichtige habe ich mal rot markiert. Gesamte physikalische Auslastung bei etwa 4 GB, die "eigene physikalische Auslastung" belegt davon aber nur etwa 1,3 GB.
Ganz oben auch hier der Firefox, wieder nur mit 0,5 GB.

Ich habe mich im Internet etwas belesen und nun einfach probeweise mal die Dienste "superfetch" und "Windows Search" (Indizierungsdienst) deaktiviert, keine Besserung.

Ich glaube ich habe mittlerweile aber die Ursache ausgemacht - der Anstieg des RAMs tritt genau dann auf, wenn ich einen Ordner öffne, der große Dateien enthält. In meinem Fall sind das Ordner mit je einem Film in HD Qualität, Größe zwischen 9 und 20 Gigabyte. Sobald ich einen Film markiere (nicht abspiele, nur die Datei im Explorer markiere) steigt die RAM-Auslastung schrittweise bis zum Maximum an.
Wenn ich den Ordner geschlossen habe nimmt sie nach einigen Minuten schlagartig wieder ab und ich bin bei meinen normalen 1 GB.

Hat jemand eine Idee was dieses RAM-Leck verursacht und wie ich das Problem beheben könnte? Bin für jede Idee dankbar und gewillt alles auszuprobieren. Wenn weitere technische Details benötigt werden reiche ich die gerne nach.

Die Dateien schließe ich als Verursacher aus, auf meinem Laptop (Win 7 Home Premium x64) laufen sie einwandfrei.

EDIT: Ich kann die FIlme problemlos ohne RAM-Anstieg abspielen, wenn ich sie per VLC öffne und den Windows Explorer aussen vor lasse. Auslastung beim abspielen nicht höher.
[Bild: zaiendosig.php]
Antworten
#2
Hmm - sehr seltsam...
Also ich hab bei großen Filmdateien beobachtet, dass, sobald man einen Film markiert, dieser wohl durchsucht wird und unten in der Statusleiste ein 'Vorschaubild eingeblendet wird. Bei mir verändert sich die Ram-Auslastung dabei aber kein bisschen. Wenn bei mir viele Filme in einem Ordner oder direkt im Hauptverzeichnis der HDD liegen und ich dieses Verzeichnis öffne, 'hängt' der Explorer kurz bzw. es läuft oben der grüne Ladehbalken durch, bis die Dateieigenschaften eingelesen sind. Auch dabei verändert sich die Auslastung nicht, man hört nur die HDD rattern. Beide o.g. Phänomene sind identisch, egal ob SD- oder HD-Filme vom Digitalsat aufgezeichnet...
Betrifft aber wohl beides nicht dein Problem..

Aus den Daten, die dir der "Process Explorer von Sysinternals" anzeigt, werd ich auch ned grad schlauer.


   

Haste aber mal im Taskmanager den "Ressourcenmonitor" aufgerufen? In dem gibts ja das von mir eingerahmte "Für Hardware reserviert"... vlt. Hardwarebedingt (vlt. querschießender Hardwaretreiber)?
Du hast ja vor ner Weile dein System neu aufgesetzt - ich frag mich, ob da vlt. irgendein Treiber ned passt, der aber von Windows fürs Einlesen von Videodaten verwendet wird oder irgendwas in der Richtung. Auch schon mal mit den Darstellungsoptionen im Explorer gespielt? Also Umstellen von 'Detailanzeige' auf 'Liste' oder 'Kacheln'...
greets
mr.tommi
Antworten
#3
Also ich hätte auch als erstes gesagt Superfetch abschießen, hat bei mir bei der Win7 RC den Speicher immer vollgeladen. Wenns daran nicht liegt... Andere amoklaufende Dienste evtl? Wie tommi sagte, spinnende Treiber? Ansonsten: Hast du vielleicht ein Codec Pack installiert? Dort liegt oft Software zur Analyse von Mediendateien bei und läuft oft im Hintergrund als Dienst o.Ä.

Was man sonst versuchen sollte, auch wenns eigentlich nicht mit den Filmdateien zusammenhängen kann/sollte:
- Virenscanner deaktivieren
- Wenn installiert bei Virtual Clone Driver den Haken bei "Buffered I/O" entfernen
Ziemlich unwahrscheinlich, dass es daran liegt, aber immer probieren bevor man etwas ausschließt Wink
I'm sorry, Dave. I'm afraid I can't do that.
Antworten
#4
Moin ihr beiden,
Superfetch wie gesagt schon abgeschossen. Für Hardware sind bei mir 2 MB reserviert, die Auslastung steht bei "In Verwendung".
Treiber sollten einwandfrei sein weil WIndows ja normal installiert wurde.
Andere Dienste die das verursachen könnten wäern mir nciht bekannt.

Codec Pack ist vorhanden, verwende Shark007's Windows 7 Codec Pack. Habe das testweise mal deinstalliert, leider keine Veränderung.
Avira AntiVir müsste ja dann eigentlich als Prozess auftauchen, testweise auch mal deaktiviert - keine Veränderung.

Virtual Clone Driver habe ich nicht installiert.

Darstellung des Ordners hatte ich schon getestet, kein Unterschied bei den Darstellungsformen.

Danke für eure Ideen, leider bislang noch kein Erfolg. Für weitere Vorschläge bin ich dankbar Smile
[Bild: zaiendosig.php]
Antworten
#5
Puh... Da haste ja echt mal was verbrochen Big Grin

Hm, Thumbnails mal deaktivieren?
Explorer öffnen > Alt-Taste drücken > Extras in der neuen Menüleiste > Ordneroptionen > Ansicht > Immer Symbole statt Miniaturansicht anzeigen
Da nen Haken machen und schauen obs dann besser klappt...
I'm sorry, Dave. I'm afraid I can't do that.
Antworten
Werbeagentur gesucht? PRinguin, die Digitalagentur. Für Web Entwicklung und Online Marketing.
Registriere dich (kostenlos) um diese Werbung zu verbergen.
#6
Hi Lennart dein Problem hört sich sehr ähnlich an was ich mal hatte.
Guck mal ob du einen Prozess namens "Systemunterbrechung" findest.
Der war bei mir damals das Problem. Ich wäre auch fast verzweifelt weil es immer aus dem nichts kam das der Computer so langsam wurde.

Ich schlage dir vor ein Bios Update zu machen. Ich hatte damals auch alles versucht und bin fast verzweifelt. Aber nach dem Update war alles perfekt. Also versuche es mal ich hoffe es hilft.
Computer dienen uns zur Lösung von Problemen, die wir ohne sie nicht hätten.
Antworten
#7
@ Ben: Es ist bei Lennart ja nicht zufällig, dass das System fast einfriert, sondern genau rekonstruierbar (aufrufen eines Ordners mit großer Videodatei).

Aber Bios-Update ist natürlich kein schlechter Tip, obwohl es vorm Neuinstallieren diesen Fehler wohl nicht gab...

Was mir dazu noch einfällt: hast du Win7 die ganzen Treiber (auch fürs Mainboard etc) suchen lassen? Oder haste die händisch vom Chipsatzhersteller geholt? Microsoft stellt ja nicht in jedem Fall ausreichend neue oder passende Treiber bereit - ich musste auch mal die Chipsatztreiber für mein Intel ICH9 extra laden, da Fehlfunktionen und nicht alles erkannt...
greets
mr.tommi
Antworten
#8
Moin Leute, danke für eure Ideen und Hilfe!
Thumbnails sind leider nicht die Ursache, einen Prozess namens Systemunterbrechung habe ich auch nicht.

Bios ist auf der letzten Version geupdated, per @bios.

Windows 7 hat alle Treiber selbst geladen, wird aber auch alles erkannt im Geräte-Manager (abgesehen vom Epson Scanner).

Eine interessante Neuigkeit habe ich aber: Wenn ich die Filme von meiner über USB 2.0 angeschlossenen externen Festplatte auswähle und abspiele tritt das Problem nicht auf. Nur bei der internen Platte mit identischem Ordner läuft der RAM voll. Könnte das ein Problem der Auslagerungsdatei mit Windows sein?
[Bild: zaiendosig.php]
Antworten
#9
Das mit der Auslagerungsdatei klingt nicht schlecht, da hatte Windows 7 bei mir auch schon mal von selbst dran rumgemeckert.
   
Evtl. könntest du mal unter Ordnereigenschaften den Ordnertyp verändern und entsprechend anpassen?
Das hat mir auch schon oft geholfen, wenn ein Ordner zb sehr viele Bilder enthält.
Evtl. könntest du auch mal ausprobierern die Windows Indizierung auszuschalten? Weil du ja sagst, dass es beim Ordner aufrufen geschieht.
Brauche ich dir zwar nicht zu sagen, aber für andere Wink : Die Indizierungsoptionen finden sich direkt in der Systemsteuerung.

Warum isn das Bild nun zu groß? War doch sonst immer so schön klein Confused
[Bild: artikel_logo_3098.jpg]
Antworten
#10
Bei den Bildgrößen hatten wir was verändert...

Indizierung ist abgeschaltet. Ordnereigenschaften sind eine Idee, haben aber nicht geholfen.

Ich habe es aber offenbar geschafft, ich habe die Auslagerungsdatei auf allen Laufwerken deaktiviert und seit dem steigt der RAM nicht mehr an... seltsame Sache. Eigentlich möchte ich die Auslagerungsdatei aber nutzen - jemand eine Idee woran das liegen könnte, dass sich der RAM so anstellt wenn die Auslagerungsdatei da ist? Steht übrigens auf "Automatisch vom System verwaltet" wenn der PC verrückt spielt.
[Bild: zaiendosig.php]
Antworten
Registriere dich (kostenlos) um diese Werbung zu verbergen.


Möglicherweise verwandte Themen...
Thema Verfasser Antworten Ansichten Letzter Beitrag
  [Vorstellung] Entwickler bringt Ubuntu-Desktop auf Windows 10 ohne virtuelle Maschine Lennart 0 2.228 11.07.2016, 17:31
Letzter Beitrag: Lennart
  PC läuft nicht mehr!! weltbummler 10 2.839 15.05.2012, 15:21
Letzter Beitrag: weltbummler

Verlinke dieses Thema:

Teile es auf:
Twitter Facebook Stumble Upon Delicious Google GMail LinkedIn



Benutzer, die gerade dieses Thema anschauen: 1 Gast/Gäste